we_universal Style "we_universal"

English support forum
v12mike
Junior Member
Posts: 28
Joined: Sun Jun 11, 2017 11:22 am
Gender: None specified None specified

Re: Style "we_universal"

Post by v12mike » Sun Aug 06, 2017 9:20 am

nextgen wrote:
Sun Aug 06, 2017 8:59 am
v12mike wrote:
Sun Aug 06, 2017 8:42 am
In the post above!!
You are not authorised to download this attachment.
Try this...

Ignore the column of numbers on the right, that is a problem that is already fixed.
Attachments
FCF screen capture 1.JPG

https://ginernet.com/cdn/imagenes/banners/500x90-es.gif
User avatar
nextgen
Fundador del sitio
Posts: 155
Joined: Sat Apr 30, 2011 12:04 am
Gender: Male Male

Re: Style "we_universal"

Post by nextgen » Sun Aug 06, 2017 9:36 am

Image

This is a bug from phpBB

v12mike
Junior Member
Posts: 28
Joined: Sun Jun 11, 2017 11:22 am
Gender: None specified None specified

Re: Style "we_universal"

Post by v12mike » Sun Aug 06, 2017 11:09 am

nextgen wrote:
Sun Aug 06, 2017 9:36 am
Image

This is a bug from phpBB
I agree that it is a prosilver bug which was not fixed properly in https://tracker.phpbb.com/browse/PHPBB3-15023

What do you want to do, submit a patch for prosilver, or mask the issue in we_universal, or ignore it?

User avatar
nextgen
Fundador del sitio
Posts: 155
Joined: Sat Apr 30, 2011 12:04 am
Gender: Male Male

Re: Style "we_universal"

Post by nextgen » Sun Aug 06, 2017 11:30 am

v12mike wrote:
Sun Aug 06, 2017 11:09 am
nextgen wrote:
Sun Aug 06, 2017 9:36 am
Image

This is a bug from phpBB
I agree that it is a prosilver bug which was not fixed properly in https://tracker.phpbb.com/browse/PHPBB3-15023

What do you want to do, submit a patch for prosilver, or mask the issue in we_universal, or ignore it?
The ideal would be corrected the error, but hide it or ignore it does not help anything, how it looks with the patch that you have placed?

You are verified that it does not affect other areas of the style?

v12mike
Junior Member
Posts: 28
Joined: Sun Jun 11, 2017 11:22 am
Gender: None specified None specified

Re: Style "we_universal"

Post by v12mike » Sun Aug 06, 2017 1:59 pm

nextgen wrote:
Sun Aug 06, 2017 11:30 am
v12mike wrote:
Sun Aug 06, 2017 11:09 am
nextgen wrote:
Sun Aug 06, 2017 9:36 am
This is a bug from phpBB
I agree that it is a prosilver bug which was not fixed properly in https://tracker.phpbb.com/browse/PHPBB3-15023

What do you want to do, submit a patch for prosilver, or mask the issue in we_universal, or ignore it?
The ideal would be corrected the error, but hide it or ignore it does not help anything, how it looks with the patch that you have placed?

You are verified that it does not affect other areas of the style?
I have applied the patch at https://frenchcarforum.co.uk/forum/ so you can see the effect there if you use a browser in responsive test mode on the 'active topics' page.

Generally the pagination wraps nicely now, although the posting time and forum do not wrap as nicely as I would like (but that is a different prosilver issue).

It is difficult to be sure that there are no side-effects, but I have not seen any yet, and I have asked my moderators to look for them.

If I was making a patch for prosilver it would be different, as I would change the html template in addition to the css.

Added in 2 hours 16 minutes 50 seconds:
I have looked at the original bug in prosilver, and have made a patch which I think fixes it in a sensible way.

The interesting thing is that the fix in in viewforum_body.html, search_results.html, common.css and responsive.css. As we_universal supplies its own version of these files, the fix needs to be reapplied there anyway (different to my first fix).

v12mike
Junior Member
Posts: 28
Joined: Sun Jun 11, 2017 11:22 am
Gender: None specified None specified

Re: Style "we_universal"

Post by v12mike » Mon Aug 07, 2017 12:50 pm

For the pagination formatting issues I am making an upstream PR for prosilver, and have made a PR https://github.com/melvingb/we_universal/pull/6 for we_universal. The we_universal PR is almost standalone, but requires one minor edit in the prosilver common.css file:

Code: Select all

* Pagination in viewforum for multipage topics */
.row .pagination {
	display: block;
	margin-top: -12px;
}
needs to be changed to:

Code: Select all

* Pagination in viewforum for multipage topics */
.row .pagination {
	display: block;
	margin-top: 0;
}
This same change will be made in prosilver upstream, so there is no conflict.

User avatar
nextgen
Fundador del sitio
Posts: 155
Joined: Sat Apr 30, 2011 12:04 am
Gender: Male Male

Re: Style "we_universal"

Post by nextgen » Mon Aug 07, 2017 6:06 pm

In the code changes this code change the value

https://gist.github.com/marc1706/008db6 ... -diff-L579

Code: Select all

 /* Pagination in viewforum for multipage topics */
 .row .pagination {
 	display: block;
-	margin-top: 0.3em;
+	margin-top: -12px;
}
It would leave the code as it was before the change, If they changed that code they will have their reasons but personally I fail to understand me which is.

User avatar
COB16
Junior Member
Posts: 13
Joined: Sun Jul 30, 2017 3:56 am
Gender: Male Male
Contact:

Re: Style "we_universal"

Post by COB16 » Wed Aug 09, 2017 7:39 am

How to return the width of the style as in the old version?

v12mike
Junior Member
Posts: 28
Joined: Sun Jun 11, 2017 11:22 am
Gender: None specified None specified

Re: Style "we_universal"

Post by v12mike » Wed Aug 09, 2017 10:49 am

COB16 wrote:
Wed Aug 09, 2017 7:39 am
How to return the width of the style as in the old version?
Personally I don't like the old behaviour because the width is fixed regardless of the user's screen width, so on a high resolution display, there are large blank bands either side of the content.

But to revert that change:

in file: styles/we_universal/theme/common.css find the lines:
.inventea-wrapper,
.inventea-dashboard,
.inventea-footer {
box-sizing: border-box;
width: 95%;
max-width: 1170px;
margin: auto;
}

User avatar
COB16
Junior Member
Posts: 13
Joined: Sun Jul 30, 2017 3:56 am
Gender: Male Male
Contact:

Re: Style "we_universal"

Post by COB16 » Thu Aug 10, 2017 5:02 am

The mobile version also has a problem
Image

Post Reply